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First, we thank you for choosing EagleRock Products. Our desire is to increase your efficiency through the
automation that CNC provides. Out of this desire, we have written our Draftsight User Guide; CAD
documentation with granite fabricators in mind.

This paper covers the aspects of CAD that are specific to granite fabrication, while avoiding some of the
more complex aspects that are unnecessary for fabrication. We do not want to waste your time with
information you may never use.

This user guide is meant to be a day to day reference and used in conjunction with EagleRock’s DraftSight
video tutorials. The video tutorials serve as an introduction to DraftSight. This manual picks up where the
videos leave off and serves as a guide for you to reference as you work.

If you would like to watch the videos, just follow this link
https://eaglerockproducts.freshdesk.com/support/home and scroll down to Video Tutorials section. There
you will find the video tutorials in their entirety, as well as tutorials about specific tools and commands. You
can search through the video tutorials and our other documentation by entering your search query into the
“‘How can we help you today?” box.

At the end of the document is a cheat sheet, meant for quick reference. To print it out a new copy, open this
document on a computer that is connected to a printer. Then scroll down to the cheat sheet and jot down its
page number, which is on the bottom right of the page. Click on File » Print. In the print dialog window,
select Pages and enter the cheat sheet’'s page number. Then click print.

To search through this file, use the search function of your PDF reader. For most PDF readers, you can
hold the CTRL key and press the F key to bring up the search dialog.

Software, such as DraftSight, is constantly being updated. Because of this, EagleRock’s DraftSight User
Guide will also periodically change. To make sure that you are using the newest available version of this
user guide, just scroll to the top of any page to see the version number. Then go to
https://eaglerockproducts.freshdesk.com/support/solutions/folders/5000227440 to see the current version of
our documentation.

If you have any questions, suggestions, or find an error in this guide, feel free to contact us using the
information found in the footer section of this document.

The Formatting Used in this Document

Before beginning, we need to give the formatting of this document a quick explanation. Each section or
subsection is designated by a heading and every heading is linked to in the table of contents. To skip to a
specific heading, just go to the table of contents and click on the section you wish to read.

Links are blue and underlined. Clicking on them will either take you to specific parts of this document, or
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open a web browser to a URL.

When referencing a chain of items that are clicked with the mouse, an arrow - is shown indicating the next
item on which to click. The label of the menu item or button that is to be clicked is italicized. For example,
File > Save, is instructing you to click on File and then click Save.

Commands that are entered into the command window are designated by a monospace font to
distinguish them from other text. When commands are given their own line they will be indented and in a
grey box. Aside from the command, the command prompt, either : or >> and other text may also be written

out. In these cases, remember that you do not need to enter the command prompt itself when entering a
command; it is written out to better portray what the command windows looks like in the real world:

line

Options: Segments, Undo, Enter to exit or
Specify start point>> @5-1/2,10.5

In these examples, the commands would be: 1ine and @5-1/2,10.5 respectively.

Text between less than and greater than signs designates either comments or actions that take place
outside of the command window, such as using the mouse to make selections:

ellipse <specify 1st axis start/end> <specify 2nd axis radius>

Lastly, command window examples, such as the one below, may contain spaces. In these cases, the space
bar serves the same function as the enter key, so it is important that you enter the spaces into the command
window.

circle 0,0 5

In this example, you would enter circle<space>0,0<space>5 into the command window.
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According to Dassault Systemes, DraftSight’s creator, DraftSight is a “straightforward 2D CAD software” with
“a familiar user interface and a minimal learning curve.” EagleRock has chosen DraftSight because this
software will enable you to quickly create complex drawings with ease and extreme accuracy.

In this guide we will start out by going over DraftSight’s user interface, then slowly build as we look at the
tools for drawing and modifying entities. By the end, you will have a good understanding of the tools needed
to draw out countertops and import cutouts from manufactures.

The files you create will be imported into AitekCAM, where the lines you draw will be used to create cuts.

If you are reading this guide for the first time, | suggest that you be at a computer with DraftSight open so
that you can try out what you are reading.

(Almost) Everything is a Command

One CAD concept that | would to explain early on is that nearly everything you do in DraftSight, from
opening a file, to zooming in, to drawing a circle, generates a command that is entered into the command
window.

For example, when you click the Save icon E, you are actually executing the save command in the
command window. You may notice that after you click the save icon, _SAVE appears in the command
window’s history, informing you that the save command was executed.

Similarly, undo 1 will undo one step; and this command: circle 2,2 1 will create a circle.
Almost everything is a command in DraftSight. This is important to know for three reasons:

1. The command window is where everything happens. If you are not sure what to do next, or what
went wrong, the answer is almost certainly in the command window.

2. The words “tool” and “command” are used interchangeably. For example, the circle tool and the
circle command are the same thing, as they both execute the circle command in the command
window.

3. Since almost everything is a command, you can undo nearly everything. For example, if you zoom
out too much, you can Edit > Undo to undo the zoom command. This gives you the freedom to

experiment, even if you are unsure of the outcome.

This concept will be covered in more detail in the command window section of this guide.
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DraftSight User Interface

The DraftSight user interface is made up of five main components, the menu bar, toolbars, drawing window,
command window, and status bar:
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EagleRock’s DraftSight User Guide will only cover the portions of these components that are normally used
while drawing countertops.

Menu bar

tA File Edit View Insert Format Dimension Draw Modify Tools Window Help

The File and Edit menus contain items that we are familiar with, such as Open/Save, and
Copyl/Paste respectively.

The View menu consists of items that pertain to the drawing window. Normally, you will access these
items through other shortcuts. For example, you can Zoom using the mouse wheel. Also, double
clicking the mouse wheel will execute the zoomfit command, which will zoom so that all entities will
fitin the window.

You will not need to use the items in the Insert menu.
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You will be using the Format menu to access the Layer... option when importing cutouts.

You may use the tools in the Dimension menu to confirm the measurements of your drawings.

The Draw menu is in many ways a copy of the Draw toolbar. However, the Draw menu contains
options for circles, arcs and ellipses that are not found in the Draw toolbar. For example, Draw -~
Circle has 6 options for drawing circles, whereas the Circle button on the Draw toolbar only has one
option.

The Modify menu is a copy of the Modify toolbar. While you can use the Modify menu, the toolbar is
easier for most.

The Tools menu contains many miscellaneous tools. You will likely only use the Tools ~» Options
item, as well as the Inquiry » Get Area & Get Distance items. Options is where you will change
DraftSight’s settings. Get Area and Get Distance are tools for measuring. They will give you
measurements without adding entities to your drawing, as Dimensions would.

The Window menu give you access to other files that may be open. Draftsight is capable of opening
multiple files at once. In the Window menu, you can arrange and select windows.

The Help menu gives you access to DraftSight’s help dialog.

Toolbars

The toolbars provide quick access to the tools and commands that you will be using. By hovering over a
tool, a tooltip with the tool’s name will appear beside the mouse pointer. There are three toolbars that you
will be using: Draw, Modify and Standard.

N OB N Ge fFa

The Draw toolbar contains all of the drawing tools that you will normally use. When selecting a tool,
the entity’s command is executed in the command window, with the default options selected. You
can select specific options for circles, arcs and ellipses from the Draw menu. Click here to read more
about this toolbar and the buttons in it.

The Modify toolbar contains the tools that modify entities, such as delete, copy, move and rotate.
Click here if you would like to read more about this toolbar.

e 3 EH & L &£ [h D 7

The Standard toolbar contains the tools necessary for working with files. Here you can open and
save drawings, copy and paste, and with the arrow buttons, you can undo and redo commands.
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If there is not enough room to display all of the toolbar’s icons, you will find an more button = ¥  at the
bottom of the toolbar, which, when clicked will display the missing buttons.

Customizing Toolbars

In DraftSight the toolbars are completely customizable. You can change which toolbars are displayed and
the location in which they are displayed. Because of this, you may find that your toolbars are different than
the ones in the image above, or in the video tutorials.

To add or remove toolbars, right click on any toolbar >~ MAIN, then select the toolbar you wish to
add or remove.

[] Properties
Command window
[] Options Toolbar
[ Tool Matrix

[ Home

[] References

[] Lighting

BN P O 8

[ ccs

[[] Component
Lock Location »|[] Dimension
Toolbars... [] Display Order ;

Customize Interface... Draw
1 Entitv CSrian

T

To move a toolbar to a new location, click and hold on the toolbar’s handle, the two vertical lines of
dots on the left side of the tool bar:

e § H

Then drag and drop the tool bar to the desired location. If the handle does not appear, right click on
any toolbar » Lock Location and then deselect both Floating Toolbars and Docking Toolbars. The
handle should now appear.

To change the order in which buttons appear on the toolbars, right click on any toolbar - Interface
> Toolbars - Select the toolbar you wish to modify and expand it by double clicking. Now you can
drag the button to the desired location on the toolbar.
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Status Bar

At the bottom of the screen is the status bar. The status bar contains drawing aids and guides, as well as
the coordinate display.

Snap | | Grid | | Ortho Polar | | ESnap | | ETrack | (106.3237,22.7170,0.0000)

To toggle a drawing aid on and off, just click its button. To change the setting of a drawing aid, just
right click on its button and select Settings. You can find more about the drawing aids and guides in
their individual sections: Snap, Grid, Ortho, Polar, ESnap, and ETrack.

The coordinate display shows the location of the mouse pointer. By default, the coordinates shown
are relative to the drawing’s origin. You can display relative coordinates by starting a line, then right
clicking on the coordinate display and selecting Relative. This will show relative polar coordinates
when you are drawing an entity.

Drawing Area

The Drawing Area is the black area in the middle of the DraftSight window. This is the area in which you will
draw.

Inside of the Drawing Area you will see the origin. The origin is the starting point for the coordinate system.
Unless you use relative coordinates, all of your coordinates will be interpreted in relation to the origin.
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If you right click on the drawing area, a menu will appear:

Enter
Cancel
Recent Input p

ESnap Overrides >

Pan
Zoom

Segments

Clicking Enter is the same as typing the enter key into the command window. Cancel will exit out of the
current command. You can also enable specific ESnaps from this menu.

Zoom & Pan
You can zoom in and out and pan in the following ways:

Rotate the mouse wheel to zoom in and out.

Click and hold the mouse wheel button to grab and pan the window.

Activate the Zoom Toolbar and use the buttons to zoom in 'iﬂ, and out I':*Ia .

The Zoom Fit command zooms so that all of the entities you have created fit in the current view.
You can either double click the mouse wheel, execute the zoomfit command (or z1a its alias) in

the command window, or click the zoomfit button & found in the Zoom Toolbar. Zoom Fit is useful
when you scale your drawing, which will cause the drawing to go well outside the bounds of your
window.

Selecting Entities

Items are selected with a selection box. Click once on an empty space in the drawing area to start the
selection box, then open the selection box until you have reached the desired size and click again to finish
the box and select the entities.

There are two forms of selection when using the mouse. You can either select entities that are entirely
within the selection box by drawing the box from left to right, or select entities that are inside or intersect with
the selection box by drawing the box from right to left.
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When drawing the selection box from the left to right, the box is designated with a solid blue line. When
drawing from right to the left, the box is a dashed green line.

In the example on the left, where the box was drawn from left to right, only the line would be selected. In the
example on the right, where the box was drawn starting on the right side, both the line and circle would be
selected.

If you have already selected an entity and would like to select another, you can add to your selection by
drawing another selection box. To deselect all entities, press the escape key. To deselect a specific entity,
hold the shift key as you draw a selection box over it.

Command Window

As | mentioned in the introduction, The command window is where everything happens. If you are not sure
what to do next, or what went wrong, the answer is almost certainly in the command window. Because of
this, it is important to learn how the command window works; however, with DraftSight's ample toolbars and
other graphical aids, you will rarely need to enter commands manually.

The command window has two prompts:

Specify:- >>

The first prompt, a colon, is displayed when no command is being run and DraftSight. When you see this
prompt you are ready to enter a command. If you want to enter a command but do not see this prompt,
press the escape key to exit out of the current command.

The second prompt, which usually starts with “Specify” and ends with two greater than signs, is displayed
when a command has been run and the command requires your input.

To execute a command or specify a value, type it in and then either hit enter, or the space bar.
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Specifying Options
Some commands have options that can be changed. The options are displayed in blue after a command

has been executed (or a toolbar button has been clicked). The current or default settings appear above the
options.

For example, after entering the fillet command, the following appears in the command window:

fillet
Mode = TRIM, Radius = 2.0000
Options: Multiple, Polyline, Radius, Irim mode, Undo or
Specify first entity>>

On the second line, we see the current settings and, on the next line, the options.
Note that even though the prompt is asking us to specify an entity, we can enter options if they are available.

The shortcut for each option is the underlined portion of the option. For example, if we wanted to change
the radius from 2.0000 to 1.0, we would enter r into the command window.

Specify first entity>> r
Default: 2.0000
Specify radius>>

Now the prompt has changed, informing us of the default radius and asking us to specify a new radius. At
this point we would enter 1, changing the radius:

Specify radius>> 1
Options: Multiple, Polyline, Radius, TIrim mode, Undo or
Specify first entity>> <specify entity with mouse>

As you can see, we have exited out of the radius option and are now back at the beginning of the fillet
command.

Command Aliases

Most commands have shortcuts called aliases. For example, T is the the alias of the fillet command.
This means that instead of writing fillet into the command window, you only need to enter:
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In each section of this guide, common commands are listed with their aliases. You can also find a complete
list of commands and their aliases by going to Help » Help... » Command Reference » Commands listed in
alphabetical order.

Help

Included with DraftSight is an exhaustive help file. To access it, from the menu bar select Help > Help...

There are three main areas of the Help window, the Contents, Index and Search.

Contents | Index [ | Search | Welcome 5|
Index [

Search for: [ ' h Search
Look for;

[ ] + | Advanced search

2D Solids F 0 - 0 of 0 Hits
3D Faces

3D Meshes

3D Operations

3D Orbit [}
3D Polvaon Meshes

The Contents tab orders all of the help files in a logical order, for those who wish to read the help file
as if it were a book.

The Index tab is a list of all article titles. You can search through the titles by typing your query into
the Look for box.

The Search tab allows you to search for all occurrences of a word inside the individual help articles.

If you would like to find an article about something in Draftsight’s Help, first try the index, if you are not able
to find an article there, use the Search tab to broaden your search.

Creating new files

When DraftSight is first opened, it opens to a blank drawing. You can use this to create a new file, or you
can click File > New ~ Open to start a new file using the standard template.
Saving files

One of the first things you need to do when creating a drawing is to save it. DraftSight has an autosave
function, however this will only work if you have first saved your file.
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To save a file, click File > Save. If the file has not been saved before, you will be prompted to specify a
filename. The recommended location for saving drawings is the My Drawings folder, which is in the
Documents folder.

Before you save, make sure that the file type is set to R2007-2009 ASCII Drawing by clicking on the Files of
type dropdown box and selecting the aforementioned file type. This is the file type that is best compatible

with the AitekCAM software.

A Save As =

|/ | home | aitek | Documents | My Drawings |

Look in: | B3 /homefaitek/Documents/My Drawings ¢ | 48 = 4 (4 @ E‘

Computer examples | Testl.dxf
E aitek | example.dxf — | Test2.dxf
{b | example2.dxf

B3 bclca1ba-f71e-49dc-bbao-.. [ homefaitek/Documents/My Drawings
Documents | exampled.dxf

Pictures | example sink 1.dxf

Videos | NONAME_0.dxf

| NONAME_20.dxf

File name: [NONAME_def l| save |

Files of type: |R200?—2009 ASCII Drawing (*.dxf) o | | Cancel |

As you can see in the image above, there is a shortcut to My Drawings folder on the left side of the Save As
window.

Open files

To open a file, click File > Open. Make sure you are in the correct folder by selecting the My Drawings folder
from the left side of the open window. Select your file and click open.

Deleting files

Eventually, your My Drawings folder may become cluttered with old drawings. To delete unneeded files, you
can use the computer’s file browser.

First, click the Ubuntu button in the bottom left corner of the screen “# > Places ~ Documents -~ My

Drawings. Select the drawings you wish to delete and tap the delete key on the keyboard to move the files
to the Trash.
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A= Accessories >
CNC >
—
 Graphics > Home Folder
@ Internet > Desktop
H! office )|@
— ;
< Programming > Music
.
iy sound & video > Pictures
.
‘;} System Tools = Videos
@ Wine N Downloads
Ubuntu Software Center B computer
| ) 17 GB Filesystem
System 3| (= Floppy Drive
Lock Screen % Network
Log Out aitek... Connect to Server..
Shut Down... Search for Files...
o & | 'h [Draftsight] Recent Documents >

If you accidently delete a file that you wish to keep, select Trash from the left side of the file browser, (see
image below) right click on the file you want to restore and select restore. Your file will now be recovered.

aitek

Trash
=3 Desktop
[ File System . .
Network .@ Open with gedit
g 17GBFiles... & LEEUEE @ open with nautilus it
3 Floppy Drive o2 Open with Other Application...
“Wash
Documents \\ Cut
Music new opy c
Pictures
Videos
Downloads Copy to >
Move to >

Delete Permanently

Properties

Coordinates

In nearly all of your interactions with the drawing area you will be entering coordinates to define points. For
example, to draw a line you will specify the coordinates of the line’s start point and end point; to draw a circle
you will specify the coordinates of the circle’s center and radius.

With DraftSight’s ample tools, you will not need to rely solely on entering coordinates manually, but will be
able to use the mouse for much of your drawing.
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DraftSight works with two formats when entering fractions. You can use a decimal: 1.75; or you can use a
fraction 1-3/4. When entering fractions, be sure to separate the integer and the numerator with a - (dash),
not a space.

DraftSight accepts the input of two different coordinate systems, the Cartesian coordinate system and the
polar coordinate system. Within those two systems, coordinates can be entered either as absolute
coordinates or as relative coordinates.

Cartesian Coordinate System

The Cartesian coordinate system defines points by their position on the X and Y axes:

YA
) (%,3)
(;3’1) 1
(0,0 x
5 Lt 3
o —_—
1525 |,

The Cartesian Coordinate System

Most likely you are already familiar with the Cartesian coordinate system. The origin of this system is the
intersection of the X and Y axes. Y increases as you move up and decreases as you move down. X
increases as you move right and decreases as you move left.

Polar Coordinate System

The polar coordinate system uses a less familiar method in designating points. This system defines points
by a distance and an angle. The distance refers to the distance from the origin and the angle refers to the
angle from a line that starts in the origin and goes right (see figure below). The angle increases as it moves
counter clockwise around the origin:
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The Polar Grid

On the grid are 3 three points:

e The red point is 3 units from the origin at a 45° angle.
e The green dot is 3 units from the origin at a 180° angle.
e The blue dot is 1 unit from the origin at a 337.5° angle.

Absolute vs Relative

DraftSight accepts the input of both absolute and relative coordinates. The distinction between absolute and
relative coordinates may be a new concept.

To explain this concept, | will use the pages in this manual as an example. Let’s say that | want you to read
pages 9, 10, 11 & 12 of this manual. There are two ways | might ask you do this:

e Read pages 9 to 12.
e Start on page 9 and read 4 pages.

In the first example, | referred to the pages as numbered from the first page. This is analogous to using
absolute coordinates. Both of my page numbers were in relation to page 1, a page number which is fixed, or
absolute.

In the second example, | told you to start on page 9 and from that point, read 4 pages. This is analogous to
using relative coordinates. When | asked you to “read 4 pages”, | was using page 9 as a starting point. In
this sense, the 4 pages are relative to the starting point of page 9.


http://www.eaglerockproducts.com/
mailto:support@eaglerockproducts.freshdesk.com

(’-\l EagleRock

PRODUCTS
\\_l,

Let’s look at another example. Below is a drawing of two lines, one line extending from points A to B and
the other line extending from B to C:

If we were tell someone how to draw these lines, we would likely tell them to first draw a 5 unit line, and
then, from the end point of the first line, draw a 7 unit line.

In doing so, we would have given the second line using relative coordinates, because the start point of the
second line was drawn in relation to the end point of the first line. Our origin (the 0 point) changed places
while we were drawing. We drew from O to 5 to draw the first line, and then started at 0 once again,
measuring out 7 units to draw the second line.

With relative coordinates, the origin is relative to the last point you entered.

On the other hand, if we were to use absolute coordinates to explain the diagram above, we would say to
draw a line from 0 to 5, and another line from 5 to 12. This is because we would measure out from 0 (point
A) for every measurement.

In general, the measurements you use to create drawings will be relative to other measurements, not a
single fixed point.

Absolute Coordinates

By default, when you specify coordinates in DraftSight they are interpreted as absolute coordinates,
meaning that they are they are relative only to the the origin of the drawing. The drawing’s origin is in a fixed
(absolute) location and never moves. The origin’s location is represented by this symbol:

Absolute coordinates are not something that are normally relied on in granite fabrication. However, it is
important to understand how they work.

Absolute Cartesian
DraftSight’s syntax for absolute cartesian coordinates is: X, Y with no spaces.
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For example, in the diagram above the coordinates of the blue dotare -1.5,-2.5, and the green dot’s are
2,3

If we wanted to draw a line from the blue dot to the green dot, we would specify -1.5,-2.5 as the start
point and 2, 3 as the end point.

Absolute Polar
Draftsight’s syntax for absolute polar coordinates is: length<angle with no spaces.

90

135 25— 67.5 45
157.5 22.5
(13 \
180 \ ! / 0(360)
202.5 \\ 337.5
225 5475 292.5 315

270

For example, in the diagram above, the coordinates of the red dot are 3<45 and the blue dot are 1<337.5.
If we wanted to draw a line from the red dot to the blue dot, we would specify 3<45 as the start point and

1<337.5 as the end point.
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Relative Coordinates

As we discussed earlier, when drawing with relative coordinates, the origin is the last point that was drawn.
Since relative coordinates depend on a previous point, they can not be used to start an entity. The first point
needs to be entered using absolute coordinates; once the first point has been entered, a point relative to it
can be drawn. Relative coordinates are designated by an ampersand, or “at sign”.

Relative Cartesian Coordinates
The syntax for relative Cartesian coordinates is @X,Y with no spaces.

YA
(2,3)

2

(13.1)

(=1.5-25) | -

For example, in the diagram above, to draw a line from the red dot to the origin (0,0), we would start the line
using absolute coordinates, -3, 1, then we would specify relative Cartesian coordinates: @3, -1 DraftSight
will then count 3 to the right and one down from the red dot, and draw a line to origin.

If we wanted to draw a rectangle 55 units wide and 26 units tall, we could specify our start point with the
mouse on a random part of the drawing area, and then enter @55, 26 as the opposite corner.

Relative Polar Coordinates
The syntax for drawing relative Cartesian coordinates is @distance<angle.

For example, in the diagram above, to draw a line that starts at the blue dot and follows the dashed line
straight up to the X axis, we would first start our line at-1.5,2-2.5 and then enter @2.5<90. This will
draw a line of 2.5 units at a 90° angle. Similarly, starting a line at 2, 3 and entering @3<270 will draw a line
from the green dot to the X axis.
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Now that we have covered how to enter coordinates, we can move to drawing entities. The Draw Toolbar
contains all of the shapes you will be using, however, the Draw menu from the menu bar contains a few
extra options for drawing circles, arcs and ellipses.

Line

The line tool is straightforward; it draws a line using a start and end point. The continuous option starts a
new line at the endpoint of the previous line. This speeds up the drawing process, since you only need to
specify the next point.

Line Quick Reference

Command line
Alias 1
Toolbar
c\:
Menu bar Draw - Line
Important Continuous - (Default) Automatically uses the endpoint of the previous line as the
Options start point of the next line.

Segment - When a line is finished, prompts user to specify a new start point for the

next line.
Command
Window : line 0,0 @3<45
Examples
10,0 @5,0
Rectangle

The rectangle tool requires the points of two opposite corners to draw a rectangle.

Rectangle Quick Reference
Command rectangle

Alias rec


http://www.eaglerockproducts.com/
mailto:support@eaglerockproducts.freshdesk.com

Toolbar

Menu bar

Important
Options

Command
Window
Examples

Circle

(’-\l EagleRock

PRODUCTS
\\_l,

=

Draw -~ Rectangle

N/A

rec <specify start point with mouse> @50, 26

The circle command has many options, as you can see by going to Draw -~ Circle. The two most relevant
options are drawing a circle with a center point and either a radius or a diameter. Select one of the two
options from the menu bar and then click once to specify the center point and then enter either the radius or

diameter.

Command
Alias

Toolbar

Menu bar

Important
Options

Command
Window
Examples

Circle Quick Reference
circle

d
@

Draw - Circle » Choose option

Menu bar:
Draw - Circle » Center, Radius - Specify the center and then the radius.
Draw - Circle » Center, Diameter - Specify the center and then the diameter.

Command Window: (after specifying the center)
Diameter - Specify a diameter instead of a radius.

circle 0,0 5

circle <specify center point with mouse> d 5
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The arc command draws a portion of a circle. Arcs can be defined using many options as you can see in
the Draw > Arc menu. However, the two most relevant options are drawing arcs using 3 points, or using a
start point, end point and a radius.

The 3 point option is useful when you do not know the radius, but know three points along the radius’s path

takes.

One thing to keep in mind is that arc start points and end points are drawn counter clockwise. Remember
this when you create an arc, otherwise it may be concave instead of convex or vice versa.

Command
Alias

Toolbar

Menu bar

Important
Options

Command
Window
Examples

Ellipse

Arc Quick Reference

arc

%E

Draw - Arc~> Choose option

Menu Bar:
Draw -~ Arc ~» 3 Points - Specify three points which the arc will pass through.
Draw > Arc » Center, Diameter - Specify the center and then the diameter.

Command Window:
(The default option is to specify 3 points: start, through and end)
Center - Specify the center, then a start and end point.

arc <select 3 points using mouse>

a Cc <select start/end points using mouse>

According to DraftSight’s help file, “An Ellipse has a center like a Circle, but has a longer radius along its
major axis and a shorter radius along its minor axis.” Basically, ellipses are circles that have been stretched.

Ellipse Quick Reference
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ellipse
el

&

Draw - Ellipse~ Choose option

Menu Bar:
Draw - Ellipse > Center - Draw by first specifying the center, then end points.
Draw - Ellipse » Axis, End - Draw by first specifying an axis, then end point of
other axis.

Command Window:
(The default option is to specify 3 points: first axis start, first axis end and
second axis radius)
Center - Specify the center, then a start and end point (first, second radius).

ellipse <specify 1st axis start/end> <specify 2nd axis
radius>

el c <specify center> <specify 1st axis radius> <specify 2nd
axis radius>

Just as an arc is a portion of an circle, the elliptical arc tool creates a part portion of an ellipse. Keep in mind
that elliptical arcs are drawn counter clockwise.

Also, note that the elliptical arc is not an independent tool, but an option of the ellipse command.

Command
Alias

Toolbar

Menu bar

Important
Options

Elliptical Arc Quick Reference
ellipse
el

%

Draw - Ellipse~ Arc

Menu Bar:
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Draw - Ellipse - Arc - First, draw an ellipse by specifying the start, end and
other axis. Next, specify the start angle (start point) of the elliptical arc, and
then the end angle. Remember to draw your start point and end point
counterclockwise.

Command Window:
After executing the ellipse command, enter e to choose the elliptical arc option.
By default, you will be prompted to specify the diameter of the first axis.
Center - Specify the center, then a start and end point (first, second radius).

Command
Window : ellipse e <specify 1st axis start/end> <specify 2nd axis
Examples radius> <specify arc start> <specify arc end>

el e c <specify center> <specify 1st axis radius> <specify
2nd axis radius> <specify arc start> <specify arc end>

The Status Bar contains powerful drawing aids guides that will allow you to enter most coordinates by
pointing and click with the mouse.

Snap | | Grid | | Ortho | | Polar| | ESnap | | ETrack

The guides are turned on and off by toggling their button. In the image above, the Polar guide is active and
all others are off. If you are going to try out the guides as you read them, but sure to only activate them one
by one (with the exception of ETrack, which must have ESnap on in order to function).

Each button, with the exception of Ortho has a settings window that can be accessed by right clicking on the
button and selecting settings.

Snap & Grid

The Snap and Grid guides are not useful when drawing countertops. According to DraftSight’s help file,
“With snap activated, the pointer selects only points positioned directly on the snap grid”. In Snap’s setting,
you can change the increments of the snap grid. However, for drawing out countertops it is impractical to
have a snap every 1 inch, or even 1/16ths of an inch.

The Grid button activates a visible grid. This grid does not cause the mouse to snap to it, it is simply a
visible grid. The increments in which the grid appears can be changed in the Grid button’s settings.
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Ortho

The ortho guide is a very simple and useful tool. With Ortho on, points can only be specified at 90° angles.
Also, Ortho allows you to indicate a direction with the mouse and enter a distance with the keyboard. Ortho
will automatically correct the angle to either 0°, 90°, 180° or 270°, and it will use the distance you specified
with the keyboard, not the mouse. This can help you to quickly enter dimensions in to Draftsight.

To temporarily enable Ortho, hold the shift key while you draw.

Polar

The Polar guide is similar to Ortho in that it aids in drawing on certain angles. Polar, however, is not limited
to four angles. Also, while Ortho locks you into one of four angles, Polar snaps to designated angles, but
also allows you to draw outside of the snapped angles.

To snap to an angle, move your cursor within 2-3 degrees if the angle. Once you are close the predefined
angle, a dashed and dotted line will appear extending your line beyond your cursor. This indicates that
Polar has snapped on to the angle.

Once you have snapped on to an angle, you can type a length into the command window and hit enter. The
entity will follow the path of the angle specified by the mouse, and the length specified in the command
window.

To change the designated angles, right click on the Polar button and select settings.

< Polar Guides

] Enable Polar guides (Polar)
Display Polar guides
Incremental angles for Polar guide display | 45 w

[ Display Polar guides at specific angle(s)

@ Add
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Here you can change the increments at which the Polar guide is displayed. You can also enter custom
angles to which Polar will snap.

ESnap

ESnap stands for Entity Snap. According to DraftSight’s help file, it snaps to “geometrically significant points
on drawing entities, for example, end points, intersections, and center points.” By “snapping to a significant
point”, ESnap “provides an exact position for drawing and editing commands.”

Upon enabling ESnap, you will notice that a white box is displayed around the crosshairs. This box is called
the gravity box. DraftSight targets possible ESnaps inside the gravity box. “Gravity” refers to the way that
the cursor is “pulled” into the ESnap.

To change the size of the gravity box, enter the gravity command into the command window and then
enter a new value. The gravity box pictured above is a size 18. If the gravity box is too large, it will detect
multiple ESnaps and may not use the desired one; if it is too small, it will become difficult to use.

When ESnap acquires an entity, a small marker will appear over it. If you hover over the ESnap, a tooltip
will appear with the name of the ESnap.

in

nd point

In this case, the tooltip is indicating that an end point was found, and it is displaying the end point marker (a
square) over the endpoint. Once an ESnap has been acquired, you can click and ESnap will pull your
cursor in, specifying the exact location even though the cursor is not exactly over it.

Individual ESnaps can be enabled and disabled by right clicking on the ESnap button and selecting Settings:
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~ EntitySnaps

Enable EntitySnaps (ESnaps) [ﬂ% By
Geometry ESnaps Reference ESnaps

0 4 Nearest ] " Extension

*, End

[0 > Intersection

A~ Midpoint
X\ Parallel

(= Center

. ¢ Perpendicular
[ €% Quadrant

O/ Node [J & Tangent

N .
O & Insert [ = Wisual Intersection

Enabling many ESnaps at once is not always helpful. For example, the nearest ESnap conflicts with the
parallel ESnap, making it impossible to detect a parallel snap.

ESnaps can also be individually temporarily enabled by right clicking in the drawing area » ESnap Overrides
> select the desired ESnap. This is particularly helpful if ESnaps are conflicting with each other. In the
above case, you could right click in the drawing area » ESnap Overrides ~> Parallel. This will turn the parallel
ESnap on and all others off while you specify the next point.

Enter
Cancel
Recent Input >

Inference point

From
Mid Between 2 Points

Pan

Zoom

Point Filters >

Segments
Endpoint
Midpoint

Intersection

Visual Intersection

Extension

Center
Mnadrant

You can also temporarily enable an ESnap by entering its alias into the command window. ESnap
commands are transparent commands meaning that they can be entered while another command is being
executed.

For example, if we wanted to draw a line in the center of a circle, we would first start the line and then when
prompted to specify a start point, we would enter cen, the alias for the circle ESnap.
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Options: Segments, Enter to continue from last point or
Specify start point>> cen
of <select entity to snap to center of>

The prompt then changes to “of”, referring to the center “of” a circle. The circle ESnap is now enabled
exclusively. By hovering over the edge of a circle, the circle marker will appear in the center allowing us to

click and snap to it.

Name Alias
Center Point cen
Midpoint mid
Endpoint end
Intersection int
Parallel par
Perpendicular per
ETrack

=
Y
=
X
(1)
=

E O B E [

Common ESnaps

Notes

Snaps to centers of circles, ellipses, and arcs.

Snaps to the midpoints of lines.

Snaps to the endpoints of lines, rectangles, and arcs.

Snaps to the intersection of any two entities.

Start the entity first, then select the parallel ESnap. Move

mouse along other entity until the parallel maker appears.

Start the entity first, then hover over the other entity until the
perpendicular marker appears.

ETrack stands for Entity Tracking. ETrack is a tool that helps you draw in relationship to other entities by
displaying temporary guides and markers to which you can snap. According the DraftSight’s help file,
ETrack will “snap to geometrically significant points on drawing entities, for example, end points,

intersections, and center points”.

ETrack works in conjunction with ESnap, because of this, ESnap must be enabled for ETrack to function

correctly.

ETrack markers are activated by hovering over areas such as end points, intersections, and center points

until a small blue plus sign appears. Markers can be difficult to acquire, so patience is needed.
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In the example below, an ETrack point on the rectangle was activated. The marker, a triangle, tells us that
ETrack has found a midpoint. Once the marker is activated, ETrack will display a dotted line. This dotted
line will appear whenever the crosshairs is close to 0°, 45°, 90° and so on, of the tracking point.

You can also see that the intersection ESnap marker is displayed inside the gravity box, meaning that if |
were to click, | would specify the a point along the ETrack dotted line.

In the next image, | have activated one more ETrack tracking point, this time on the midpoint of the top of
the rectangle.

You will also see that the intersection ESnap marker has now moved to the intersection of the two tracking
points. Since both of our tracking points are perpendicular to the midpoint, the intersection will be the exact

center of the rectangle.
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There is no limit as to how many tracking points can be activated at any one time.

The tools in the Modify Toolbar are used to alter and manipulate entities. The Modify Toolbar is usually
found on the right side of screen.

When using a modify tool, you can either first select the entities you wish to modify and then execute a
modify command. You can also execute the command first, and then specify your entities afterwards.

The examples below assume that you select your entities before executing a modify command, when
applicable.

Delete

The delete tool is very straight forward. Specify the entities you wish to delete and click the delete tool to
remove them from your drawing.

Delete Quick Reference

Command delete

Alias del

Keyboard Delete Key

Toolbar @

Menu bar Modify> Delete
Copy

The copy tool copies entities. When pasting entities, relative Cartesian coordinates can be useful. For
example, @5, -1 will place a copy 5 units to the right and one unit down.

Once the first copy has been pasted, you will be prompted to create another copy: Specify second
point>>. You can either specify the location for another copy or exit out of the copy command by hitting
enter.

Copy Quick Reference
Command copy

Alias co
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Keyboard Ctrl+c Copy
Ctrl + p Paste

Toolbar A

Menu bar Modify> Copy

Command

Window Example

copy
Specify from point>> <click on a point, movement will be

relative to this location>

Specify second point>> @5,-1

Specify second point>> @-5,-1

Specify second point>> <enter to exit>

Mirror

The mirror command creates a mirror image of an entity, or we could say that the mirror tool “flips an entity
over”. This will be useful if you want to create a drawing face up and then flip it over, in the same way that
you will flip your slab over to cut it on the CNC machine.

First you will specify the start point of the mirror line. The mirror line is the line on which the entity will flip. If
the mirror line is not perfectly vertical or horizontal, the mirrored entity will be tilted. The length of the line is

not important, it can be any arbitrary length as long as it distinct from the start point.

Once the mirror line has been specified, the option is given to delete the source entity.

Mirror Quick Reference

Command mirror
Alias mi
Toolbar A

Menu bar Modify> Mirror
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Command

Window Example e

Specify start point of mirror line>> <click on a point,
movement will be relative to this location>

Specify end point of mirror line>> @1<90

Confirm: Delete source entities?

Specify Yes or No>> yes

Move

This straightforward tool moves entities from one point to another. After executing the move command, you
need to specify a from point and a destination.

You may find it handy to use the the ESnap tool to select an endpoint as the from point, then use the mouse
to move the entity on that point to the desired location.

Move Quick Reference

Command move

Alias m

Toolbar A

Menu bar Modify> Move
Command

Window Example e

Specify from point>> <click on a point, movement will be
relative to this location>
Specify destination>> @0, -5

Offset

The offset tool creates a parallel entity. Below are examples of offsets of a circle, square and line:
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With circles, ellipses, arcs, and rectangles, the offset is created either closer to or further from the center
point. Because of this, the offset will be a different size.

Lines are simply copied to the location of the offset.
One situation in which offsets are useful is drawing corner sinks. In the example below, line 1 is the outer

edge of the cabinetry. To create a 1 2 inch overhang, a 1 %2 inch offset was drawn (line 2). Line one can
now be deleted and lines can be drawn connecting line 2 to the rest of the countertop.

The create an offset, first click on the offset tool and enter the desired offset distance. Next, select the
source entity and then the side on which the offset is to be placed. You may now either exit out or specify
another entity to offset with the same distance.

Offset Quick Reference

Command offset
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Alias o]

Toolbar -

Menu bar Modify~> Offset
Command

Window Example | . offset

Specify distance>> 1-1/2

Specify source entity>> <select entity to offset>

Specify side for destination>> <click on the side you wish to
create the offset>

Options: Exit, Undo or

Specify source entity>> <press enter to exit, or select
another entity to create more offsets>

Rotate

The rotate tool rotates entities around a pivot point. First you will be asked to specify a pivot point, which
can be any point. If you specify the center of the entity, it will pivot in place. Next, enter the rotation angle
and the entity will rotate.

Rotate Quick Reference

Command rotate

Alias ro

Toolbar 2

Menu bar Modify» Rotate
Command

Window Example S offsat

Specify pivot point>> @0,0
Specify rotation angle>> 90

Scale

The scale tool changes the size of entities. You can use this tool to convert from inches to millimeters.

First, a base point must be specified. The base point will remain in the same place, with all other points
expanding away from it, or contracting towards it.
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Next, the scale factor must be specified. This number will be used the multiplier by which the entities will
scale. To convert from inches to millimeters, use a factor of 25.4.

Scale Quick Reference

Command scale

Alias sC

Toolbar =

Menu bar Modify> Scale
Command

Window Example scale

Specify base point>> 0,0
Specify scale factor>> 25.4

Chamfer

The chamfer tool is used to make beveled corners. In our context, it can be used to make vertical chamfers
on the corners of counter tops.

In the image above we see the chamfered corner of a counter top. When creating a chamfer, you will need
to specify the first and second distance. This distance is the distance from the corner to the start of the
chamfer. In the image above is a two unit chamfer. You can specify unique distances for each
measurement, if desired.
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To create a chamfered corner, execute the chamfer, then use the d option to set the chamfer distances.
Then select the first line (which will use the first distance), and then select the second line.

Chamfer Quick Reference

Command chamfer

Alias cha

Toolbar =~

Menu bar Modify> Chamfer
Command

Window Example R P

Options: Angle, Distance, mEthod...

Specify first line>> d

Specify first distance>> 2

Specify second distance>> <press enter to make same as first>
Specify first line>> <click on first line>

Specify second line>> <click on second line>

Fillet

The fillet tool creates a rounded edge from two lines that end in a corner, intersect, or nearly intersect. The
size of a fillet is determined by its radius.

In the image above we see a corner that has been filleted on a 2 unit radius.

First, select the fillet tool, then enter r to change the radius. Enter the desired distance for the radius and
then specify the two entities on which to create the radius.

Fillet Quick Reference
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Command fillet
Alias f

Toolbar

Menu bar Modify- Fillet
Command

Window Example . fillet

Options: Multiple, Polyline, Radius...

Specify first line>> r

Specify first distance>> 2

Specify first entity>> <select first entity>
Specify second entity>> <select second entity>

Trim

The trim tool removes a portion of an entity by cutting it on a cutting edge. In order for a line to be trimmed,
it must intersect with the cutting edge.

To trim an entity, execute the trim command. Next, specify the cutting edges. There is no limit to the
number of cutting edges that can be specified. Also, lines designated as cutting edges can be cut
themselves. Once you have specified the cutting edges, hit enter. Lastly, click on the segments you want to
remove and hit enter to exit trim command.

In the example above, the dashed vertical line was specified as the cutting edge. By clicking on the side
labeled 2, it will be removed and only side 1 will remain.

Trim Quick Reference

Command trim
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Alias tr

Toolbar 3%

Menu bar Modify> Trim
Command

Window Example e

Specify cutting edges>> <select edges you wish to cut on>
Specify segments to remove>> <select segments for removal,
they must intersect with the cutting edge>

Specify segments to remove>> <enter, to exit>

Explode

According to DraftSight’s help file, the explode command breaks up complex entities into their component
entities.

To explode an entity, select it and execute the explode command.

The only entity covered in this tutorial that can be exploded is the rectangle. Rectangles are drawn as one
single entity. Because of this, individual lines cannot be removed from the rectangle. The explode
command breaks up rectangles into individual lines that can be modified separately.

In the example below, the rectangle on the left is an unexploded rectangle. Notice that there are not EGrips

- on the midpoints of the left rectangle. This is because the rectangle is understood as one single entity,
which similar to a circle has a center, not midpoints along its lines. On the right is an example of an
exploded rectangle. Each line can be selected and moved individually.

Explode Quick Reference

Command explode

Alias X
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Toolbar é

Menu bar Modify> Explode

Many sink manufacturers post sink cutout templates online. You can download these files and use them in
your drawings. The preferred file type is DXF (Drawing Exchange Format).

The best way to find a cutout template is to use Google and search for the model number of your sink and
dxf. For example, the first result when searching for k-3177 dxfis a page on Kohler's website with a link to
the cutout DXF file.

If you are having trouble locating a cutout, the website stonecoldcnc.com has a large list of DXF files freely
available.

Because cutout files may contain elements that are not compatible with the CAM program, it is suggested
that you copy the sink cutout and paste it into another drawing.

The sink cutout files may contain more than one cutout template. For example, the inner solid line is a no
reveal cutout, and the other is a reveal cutout. Other useful information may be found in the DXF file.

e
id o

Undertone® K-3177 cutout by Kohler
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Step One - Determine the Unit of Measurement Used

Once you download a sink cutout, you will first need to determine the unit of measurement. To do so, go to
the menu bar and click Tools - Inquiry » Get Distance to begin using the get distance tool. This measuring
tool does not draw anything, but instead gives a distance based on the points specified.

Use this tool to confirm the distance of a known measurement. The easiest way to do this is to follow a
dimension line that is already included in the file. After you specify the two points you measured, information
like this will be displayed in the command window:

Distance = 29.2500, Angle in XY Plane = 0, Angle from XY Plane = 0
Delta X = 29.2500, Delta Y = 0.0000, Delta Z = 0.0000

In this case, the distance measured was 29.2500, which corresponds with the sink width in inches. This tells
us that the drawing uses inches as its unit of measurement.

This means that the cutout can be pasted into a countertop file that uses inches, (before it has been scaled
to millimeters). If the cutout used millimeters, it should be pasted into the countertop drawing after it has
been scaled into millimeters.

Step Two (Optional) - Cleaning up the Drawing

Many times these cutout files come with unwanted entities, such as dimensions, text descriptions, center
lines, etc. These other entities can make it difficult to select the cutout for copying, without selecting
unwanted entities.

To help clean up we will working with layers. Entities can be drawn on different layers as a way to organize
them and layers can be made visible or invisible.

Extra entities, such as comments or dimensions, are usually on a different layer than the cutout. So we will
be making all layers, except the cutout’s layer, invisible.

First we need to know on which layer the cutout is. Select an entity that is part of the cutout, then from the
menu bar click Tools - Inquiry > Get Properties. A window will appear a list of properties, one of which will
be the layer, in this case _ CURVE:

LINE
Handle 7D1
Mode Model
Layer CURVE
LineColor White

Once you have identified the layer, you can close the window.


http://www.eaglerockproducts.com/
mailto:support@eaglerockproducts.freshdesk.com
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Next, from the menu bar click Format > Layers. You will now see a list of layers; find the cutout’s layer
(_CURVE in our case), right click on it and select Activate Layer-

LRSI A - = MWL R O el W LTI "

= (-] T @] —

= _SURFACE| =] C White Contin...d line —— Default 0 -7
New Layer - : : .

= DATUM_A> =] C White Contin...d line —— Default 0 7
Delete Layer - : : -

= DATUM_CS i=! O White Contin...d line | —— Default 0 7

= DATU...LA! - =] O White Contin...d line —— Default 0 7
Specify All _ ) . . .

= DATU...OIN =] C White Contin...d line —— Default 0 o,
Clear All - . - -

= DATUMS =] C White Contin...d line —— Default 0 7

Specify all but Active - Color_
Invert Selection |

Now, Right click on the layer once again, and this time select Specify all but Active. All of the layers should
be highlighted, except for the cutout’s layer.

To make these other layers invisible, click one of the highlighted layers’ green dots:

- e & 'e) -
- e e ‘o) _
- @ i O -
= _CURVE @ =] O White Contin...d line —— Default |0 Color_7
— @ = . -

This will make those dots turn grey, and the corresponding layers invisible.

Click OK to return to the drawing. You should now notice that most of the extra entities that were in the
image above have now disappeared:

You can now easily select the desired cutout.


http://www.eaglerockproducts.com/
mailto:support@eaglerockproducts.freshdesk.com
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Step Three - Copy the Cutout into a Different File

Because the manufacturers’ DXF file may have been made using a different format than our CAM program
uses, it is not recommended that you use the cutout file and send it CAM. Instead, you should copy the
cutout and paste it into another file.

Before copying, be sure to verify that the new file uses the same units as the cutout file. If it does not, use
the scale tool to convert the units.

First select the cutout’s entities and then, right click and select Copy.

Next, open a countertop file, or create a new file. Right click in the drawing area and select either Paste or
Paste as Block.

Paste (left) will paste the cutout as individual entities, and Paste as Block (right) will paste the entire cutout
as one entity:

You may prefer Paste as Block, as the cutout will become easier to select if you need to move it later on. If
you need to modify specific entities, you can use the explode tool to break up the cutout into individual
entities.

If you would like to learn more about DraftSight, more information can be found in the following places:

EagleRock’s Help Desk https://eaglerockproducts.freshdesk.com/support/home
EagleRock’s Video tutorials
DraftSight’s Help file.

o For an exhaustive list of commands, search the Help index for “command reference”
DraftSight’s YouTube Channel https://www.youtube.com/user/DraftSight
DraftSight’'s Getting Started guide
http://www.solidworks.com/sw/products/draftsight-getting-started-quide.htm



https://eaglerockproducts.freshdesk.com/support/home
https://eaglerockproducts.freshdesk.com/solution/articles/5000579755-draftsight-video-tutorials
https://www.youtube.com/user/DraftSight
http://www.solidworks.com/sw/products/draftsight-getting-started-guide.htm
http://www.eaglerockproducts.com/
mailto:support@eaglerockproducts.freshdesk.com

Coordinate Syntax

Type Syntax Examples

Absolute

Cartesian X,Y 3,5 1.5,2-3/4

Absolute i tance<angle  3<90  50<270

Polar

Relative

Cartesian @x,y @s3,5 e1,2-3/4

Relative @distance<angle @3<90 @50<270

Polar

Fractions integer-numerator , 3,4 5_13/16
/denominator

Import Cutout Workflow

1. Tools ~ Inquiry » Get Properties to find cutout’s layer.

2. Format - Layer...
Layer

right click cutout’s layer ~> Activate

3. Right click cutout’s layer again and select Specify all
but Active.
4. Click another layer’s green dot to make all other layers
invisible. Click OK.
5. Select cutout, Right click » Copy.
6. Paste itinto a new file

Export to CAM Workflow
1. Scale at a factor of 25.4

2. Mirror

3. Save as R2007-2009 ASCII Drawing (*.dxf)

Other:
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Common ESnaps

ESnap
Center Point

Midpoint
Endpoint
Intersection

Parallel

Perpendicular per

Alias Marker
cen m
mid
end =
int E4
par == |

Polar Grid

90

135 112.5 67.5 45
\ e

157.5/ \

180

N\

'

/ \22.5
\

\

202.5 /

Pas

225 5475

0(360)

\\ 537 .5

—392.5 315
270

e stonecoldcnc.com has a large list of DXF files for sink cut outs. To access them, click the
Downloads link at the top of the page.
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